[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [NOVICE] Skift til større HD



SCJ wrote:

> Den Mon, 21 Apr 2008 20:03:16 +0200
> skrev Stig Mogensen <sslug@sslug> :
> 
> 
>>......... Jeps.....og så fungerer det. Men gad vide hvorfor det fungerede
>>før, med
>> root(hd0,0) når / lå på hda4 ?. Nu ligger / på hda2, men der kan ikke
>> bootes, medmindre grub peger på root(hd0,1).
>>  
> ....... Da sejrsrusen havde lagt sig, havde cp
>> kommandoen ikke fået det hele over. Så jeg gjorde pokker i det, bootede
>> på Knoppix, og kørte
>> 
>> dd if=/dev/hdb4 of=/dev/hda2
> 
> Hmm :-)  Du må ha' været så heldig under dine tidligere eksperimenter, at
> start-delen af Grub-programmet er blevet liggende på den nye HD. Det
> ligger i afslutningen af MBR og nogle sektorer derefter. 15 stykker så
> vidt jeg husker.
> 
> Det bliver læst ind i hukommelsen og startet op. Derfra hentes
> /boot/grub/stage2 og /boot/grub/grub.conf på den partition, hvor grub i
> sin tid er installeret fra. Der har du vist også været heldig :-)
> 
> Jeg synes du skal prøve at boote op med din /dev/hdb (den "gamle)
> afmonteret, og derved finde ud af, om den har nogen indflydelse på
> opstarten.

Er gjort. Det gjorde ingen forskel. Aner ikke hvad der er sket førhen. 
 
> Prøv også at ændre i den grub.conf du mener bliver benyttet. Sæt bare et
> ekstra bogstav i et "title"-navn, så ser du det, når maskinen bootes.

Mine partitioner ser sådan ud;

Disk /dev/hda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x4a433ac3

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1           4       32098+  83  Linux
/dev/hda2               5        8104    65063250   83  Linux
/dev/hda3            8105       32420   195318270   83  Linux
/dev/hda4           32421       60801   227970382+  83  Linux

Disk /dev/hdb: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x4a433ac3

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1           4       32098+  83  Linux
/dev/hdb2   *           5        3828    30716280    c  W95 FAT32 (LBA)
/dev/hdb3            3829       11829    64268032+  83  Linux
/dev/hdb4           11830       19929    65063250   83  Linux


hvor hda så er mit nye system, på den nye HD. Hdb er det gamle setup, og er
præcist som før alt dette. Den grub.conf der ligger på hda1 er;

default 0
timeout 10
splashimage=(hd0,0)/grub/splash.xpm.gz

title=Gentoo Linux 2.6.21-r4

root(hd0,1)

kernel /kernel-2.6.21-gentoo-r4 root=/dev/hda2 vga=0x31A

da jeg jo har skilt mig af med min W2K installation, og har skiftet / fra
4de til 2en partition. Min gamle grub.conf er;

default 0
timeout 10
splashimage=(hd0,0)/grub/splash.xpm.gz

title=Gentoo Linux 2.6.21-r4

root(hd0,0)

kernel /kernel-2.6.21-gentoo-r4 root=/dev/hda4 vga=0x31A

title=Windows 2000 Professional SP4
rootnoverify (hd0,1)
makeactive
chainloader +1

og det er værd at bemærke at jeg ikke har mulighed for at boote nogen
Windows, når Grub startes.......
 
> Sæt eventuelt også  et # her:
> 
> # timeout=15
> 
> og, hvis linien findes, også her her:
> 
> # hiddenmenu
> Så får du al den tid du behøver til at kigge.
> 
> Check også lige /boot/grub/device.map. Her skal begge dine HDere være
> nævnt.

Den jeg nu bruger, ser sådan ud;

(fd0)   /dev/fd0
(hd0)   /dev/hda
(hd1)   /dev/hdb

 
> Jeg kan ikke rigtigt følge med i dine eksperimenter - For mange vektorer
> :-)

Never mind.....jeg er tilbage på hjemmebane ;o)

/Stig

-- 
* Registered Linux user #291266, with http://counter.li.org.*


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2008-05-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *