[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [NOVICE] æøå vises ikke i output fra shellscript



Hej Frank :-)

On fre, 2008-04-25 at 14:01 +0200, Frank Damgaard wrote:
> hvilket tegnsæt er det lavet i ?
> 
Det er en almindelig #!/bin/sh

> > Mit problem er at æøå slet ikke bliver udskrevet på skærmen.
> > 
> > Flere steder i scriptet skal der stå "Udført !" men det printes ud er
> > "Udf   ".
> > 
> > Det er helt sikkert et UTF-8 anliggende men hvordan er det lige jeg
> > præciserer det i scriptet ?? 
> 
> det er jo nok den "konsol" du kører i som er noget andet .

/bin/env giver bl.a dette:

TERM=xterm
LANG=da_DK.UTF-8
GDM_LANG=da_DK.UTF-8
COLORTERM=gnome-terminal

"Fejlen" opstår både i gnome-terminal og xterm.

Er det ikke muligt at lave et shellscript så æøå bliver vist korrekt i
et system sat op til UTF-8 ?

Vil nødig ændre LANG variablen, da det helt sikkert giver bøvl med andre
applikationer.

-- 
/Niels
Registered Linux user #133791
Get counted at http://counter.li.org



 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2008-05-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *