[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [NOVICE] æø å vises ikke i output fra shellscript



On Fri, Apr 25, 2008 at 12:11:05 +0200, Niels Rasmussen wrote:

> Hej alle
> 
> Jeg sidder ved en funklende ny Ubuntu Hardy 8.04.
> 
> Jeg har lavet et lille backup program.

hvilket tegnsæt er det lavet i ?

UTF-8 benytter 2 bytes til æøå, latin1 kun 1 byte.

med "hexdump -C filnavn" kan du undersøge dette.

undlades  filnavn  kan man direkte indtaste æøåÆØÅ 
og afslut med Ctrl-D

 
> Mit problem er at æøå slet ikke bliver udskrevet på skærmen.
> 
> Flere steder i scriptet skal der stå "Udført !" men det printes ud er
> "Udf   ".
> 
> Det er helt sikkert et UTF-8 anliggende men hvordan er det lige jeg
> præciserer det i scriptet ?? 

det er jo nok den "konsol" du kører i som er noget andet .


> 
> Skal det stå øverst (som i et python script) eller skal der bruges en
> "escape character" ??

Den konsol du har åbnet var sikkert sat til UTF-8 eller noget andet.

men xterm kan man prøve:
 $ export LANG=da_DK.UTF8
 $ xterm

eller

 $ export LANG=da_DK.ISO-8859-1
 $ xterm

(forudsat da_DK.ISO-8859-1 er installeret i locale)


derudover kan f.eks. bash også kræver lidt opsætning for at
fungere i 8-bit.


-- 
mvh Frank Damgaard  | 



 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2008-05-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *