[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [NOVICE] Skift til større HD



Den Mon, 21 Apr 2008 20:03:16 +0200
skrev Stig Mogensen <sslug@sslug> :


>......... Jeps.....og så fungerer det. Men gad vide hvorfor det fungerede før, med
> root(hd0,0) når / lå på hda4 ?. Nu ligger / på hda2, men der kan ikke
> bootes, medmindre grub peger på root(hd0,1).
>  
....... Da sejrsrusen havde lagt sig, havde cp
> kommandoen ikke fået det hele over. Så jeg gjorde pokker i det, bootede på
> Knoppix, og kørte 
> 
> dd if=/dev/hdb4 of=/dev/hda2 

Hmm :-)  Du må ha' været så heldig under dine tidligere eksperimenter, at start-delen
af Grub-programmet er blevet liggende på den nye HD. Det ligger i afslutningen af MBR
og nogle sektorer derefter. 15 stykker så vidt jeg husker.

Det bliver læst ind i hukommelsen og startet op. Derfra hentes /boot/grub/stage2 og 
/boot/grub/grub.conf på den partition, hvor grub i sin tid er installeret fra. Der
har du vist også været heldig :-)

Jeg synes du skal prøve at boote op med din /dev/hdb (den "gamle) afmonteret, og
derved finde ud af, om den har nogen indflydelse på opstarten.

Prøv også at ændre i den grub.conf du mener bliver benyttet. Sæt bare et ekstra bogstav
i et "title"-navn, så ser du det, når maskinen bootes. 

Sæt eventuelt også  et # her:

# timeout=15

og, hvis linien findes, også her her:

# hiddenmenu
Så får du al den tid du behøver til at kigge.

Check også lige /boot/grub/device.map. Her skal begge dine HDere være nævnt.

Jeg kan ikke rigtigt følge med i dine eksperimenter - For mange vektorer :-)

Stig C.




 


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2008-05-01, 02:01 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *